MODS2 Closed Dome Commissioning

OSA: D Gonzalez Huerta
ISp: J Morris
TM: K Newton
ISA: O Kuhn
(Dome and Cal Unit) Observers: R Pogge, O Kuhn

While doing inventory, Rick opened the MODS2 Blue IC computer and found that one of the TAXI chips on the seqeuncer board was not well seated. This may have been the cause of the sequencer problems last December. After reseating it, 30 images were taken with no apparent problem. See the note added to IT #5431 for details.

Tonight is an INAF partner science night, however it is raining and sleeting. We plan to repeat the closed dome commissioning tasks that were precluded by the sequencer problem in December.

Telescope at ZENITH and chamber lights are OFF.

02:40 UT: execMODS2 ~modseng/modsScripts/Support/modsWake.pro

02:45 UT: execMODS2 ~modseng/modsScripts/Support/sieveSnap.pro
  • mods1b.20150318 and mods1r.20150318, b 1, r 1

02:50 UT: execMODS2 pinholeSlit.cal
  • b 2-6 and r 2-6 but red channel hung on erasing the CCD before taking 7.
    • red reset cleared the problem, but I'll repeat the entire script rather than taking just the remaining exposures.

03:16 UT: execMODS2 pinholeSlit.cal
  • b 7-9 and r 7-9 but on red channel image 10, hung on "Writing Image". Script running window says
>>red go
"PING"
  • did red reset and repeated this exposure by hand (mods2r.20150318.0010.fits)

03:44: execMODS2 -f NeHgLamp pinholeSlit.cal
  • mistake --- left Vflat lamp on. Turned it off, but this turned all lamps off. I cntl-c'd the script, but still the images were readout and written images (b 10 and r 11).

03:49: execMODS2 -f NeHgLamp pinholeSlit.cal
  • b 11-13 r 12-14

03:57UT: execMODS2 sudokuMask.cal
  • b 14-19 and r 15-21

04:22UT: execMODS2 pr_sudoku.cal
  • b 20-23 and r 22-25. Good examples of dichroic & field lens ghosts.
  • instconfig dual prism (was dual grating) --- blue imcs lock failed initially. Upon retrying, locked.

04:38UT: execMODS2 wiggle.cal
  • b 24-27 and r 26-29
  • problem with all red channel images (see, e.g. mods2r.20150318.0026.fits)
    • could this have been on the earlier red spectra also, just not so apparent because they were through pinholes? The bad column in the lower left quadrant had this horizontal smearing, also the pinhole mask images.

05:05: sieveSnap
  • b28 r 30 to check on sieve spots on red image. These look horizontally smeared. I think the problem was present in all the red channel images, but is most apparent when there is light on all pixels, not just in a few pinholes or rows.

05:15 execMODS2 gg459.cal
  • r 31-32, both show this same problem.

05:19. There is a problem with mods2 red channel images taken this evening. See attached image mods2r_20150318.jpg (mods2r.20150318.0032.fits). A slit image shows horizontal banding also (33) and 2 imaging flats through r_sdss (34-35) also show similar horizontal banding but, even more prominently, dark and light sets of columns which appear to be symmetric about the midpoint in X (see attached mods2r_20150318_0035.jpg). The problem is present at least for 2 ROIs 8Kx3K and 3Kx3K and looks like a sequencer problem.

05:43 Test pixflat: b 29 and r 36

06:00 Shut down and restarted all services (except GUI) and ICs. Take another test pixflat: b 30 and r 37. No improvement.

06:05. Following http://wiki.lbto.org/bin/view/Instrumentation/TroubleshootingISS#Readout_anomalies. Power cycling heb_r.
  • turned off heb_r, after 30 seconds, turned back on heb_r
  • quit and restarted IC. Note that it says rem... bluemods.ini but this is mods2r

06:15 Test pixflat: b 31 and r 38. Same problem with red channel.

06:20 Try backing off the lamp level (5 -> 4). With 5, we were getting 58K counts in the red channel. No change.

06:30 Checked cables. Stopped calibans, IC, isis and restarted isis, then ICs, then calibans. Now I see nothing for the environmental sensors - perhaps because I stopped/restarted ISIS with env service running?

06:45: After stopping and restarting services, now I see the env reporting in the gui.
  • Note that the blue tedpower comes up off, unlike red tedpower. modsWake turns it on.
  • (07:20 UT) Taking another pair of pixflats: b 33 and r 40. These were taken with lamp off, though already the bad column in the lower left quadrant hints at the problem. VFLAT 4 ON for b 34 and r 41. No change.

~08:30: One fan over MODS rack was off (I didn't turn it on after working there in the afternoon). Turned it on. Need to be careful of airflow in rack, which is packed.

~08:40: Power cycled M2.RC. Image taken after that still shows problem (m2r 45).

08:50: Swapped fibers to read Blue HEB with Red IC and vice versa. mods2r 46 (blue heb read out with red IC) shows noise. It's the red IC.

09:00: With fibers back to normal, took another pair of flats: red 47 still shows the problem.

09:45: Swapped the host computer (took sequencer and fan out of original m2.rc and put these into the spare IC).
  • took a pair of blue/red grating flats to test. b 38 and r 100. mods2r.20150318.0100.fits looks normal. The problem was with the red IC not the sequencer. We had a suspicion about the red IC because of the problems at the start of the evening (see above). It spontaneously rebooted when a cable on the back was jiggled this evening.

10:00: Now that the red channel IC is working properly, repeating the MODS2 Closed Dome Commissioning Scripts. Starting both mods2b and mods2r from index number 200.

10:05: modsWake and sieveSnap (b 200 r 200)

10:10: wiggle.cal (b 201-4 and r 201-4)
  • blue 204 is bad - strip of noisy rows near middle (looks like a sequencer issue), but b 201-203 are OK.
  • all red ones are OK.

10:25: repeating wiggle.cal to get a clean set of blue images (b 205-208 and r 205-208)
  • OK

10:45: gg495.cal (r 209 and 210)

11:00: the series:
  • pinholeSlit
  • sudokuMask
  • pr_sudoku (blue IMCS lock failed --- as before when going from dual grating to dual prism). Worked after retrying.

11:50: start with calibrations from ~modseng/modsScripts/modsCalib/
  • grpixflats.cal (b 229 is bad)
  • grlamps.cal (b 236 is bad)
  • grlamps.cal

12:50: modsSleep

12:50: modsBias2 (bias8K, bias3K and prbias)

-- %USERSIG{OlgaKuhn - 2015-03-18}%

Comments

 
  • mods2r_20150318_0032.jpg:
    mods2r_20150318_0032.jpg

  • mods2r_20150318_0035.jpg:
    mods2r_20150318_0035.jpg

Topic attachments
I Attachment Action Size Date Who Comment
mods2r_20150318_0032.jpgjpg mods2r_20150318_0032.jpg manage 118 K 18 Mar 2015 - 05:26 OlgaKuhn  
mods2r_20150318_0035.jpgjpg mods2r_20150318_0035.jpg manage 115 K 18 Mar 2015 - 05:42 OlgaKuhn  
This topic: Commissioning > Main > WebHome > MODS2Comm4
Topic revision: 18 Mar 2015, OlgaKuhn
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback