MODS1 AGw Commissioning at LDG: 27 September 2010 UTC

Observers: R. Pogge (OSU), R. Stoll (OSU), M. Pedani (LBTO)

Telescope Operator: DHuerta (LBTO)

Software: Support: D. Miller (active optics via Tucson)

Telescope Support: M.Midkiff (LBTO)

Instrument Support: JMorris (LBTO)

Summary

Variable seeing between pretty good (0.7 arcsec FWHM) and pretty awful (2-3 arcsec). Some clouds and bright moon after midnight. Wind was gusty 10-15m/s at times.

WFS didn't work first part of the night, but Doug Miller logged in and made modifications to get it to converge. Worked well in IDL mode most times, but sometimes we were fighting variable seeing.

Found some problems with the GCS acquisition process when backgrounds are high (we had moonlight).

Took images to try to verify the calibration of the rotator zero point, verified that rotating the instrument to PA=-0.157 deg will line up N-S with the long slit mask.

Tried doing offset precision/repeatability and astrometric tests, but variable seeing and high background acquisition problems shut us down. Some of the data look good enough to do at least an equivalent of the "dice 5" offset test described in the original LDG focal station commissioning document.

Preparations

Slit Masks

Re-arrange the masks inside the MODS1 mask select mechanism so that there is a clear space between masks. This avoids the problem caused by slight misalignment of the slit mask insert/retract "grabber" mechanism we encountered last night (although we won't be using masks much if at all tonight).

New Pointing Model

The new pointing model for MODS has been loaded. Tested on sky, it gave the expected results. Tweaking the mirrors to avoid to hit the limits could have made it worse through the night.

Instrument Mounting Bolt Inspection

Mike Midkiff inspected the MODS mounting bolts at horizon pointing, checking the bottom-center bolt at 60-degree rotation intervals.

All six bolts were tight - none were loose.

Details

Dewar Fill

01:30 - Filling MODS1 dewars at Zenith. Noting that they were filled last night at the same time, and enviromental monitors show that prior to tonight's filll they are still at operating temperature. The reservoir temps are consistent with still having LN2, so they are showing about 24h hold time.

Open

01:55 Open T=10.5 RH=62% Wind ~10-15 m/s from ESE, some clouds. SX_Mirror Temp = 11.2

02:06 Slew to Pointing Star ACT0302. CA=+9 IE=-17

02:21 Needed to select the AGW mode since this is not yet automatic, or aliased as "MODS"
   selectAGW left OSU_L.cfg

Collimation Check

02:22 - Setup again, Guide Preset, to ACT-0302. Acquire was fine, DGH making adjustments.

02:25 - Preset to a fainter star to check the pointing model. ACT 0302F

02:28 - Acquire preset again to ACT 0302F... ; too tricky to assess the Pointing performance but pointing is within few arcsec

02:36 - Guide preset to ACT 0302F, elevation 81, running IDL WFS analysis.

collimate_once - some improvement...

collimate_once - seeing is very swimmy

collimate_multiple, 3, /send - hit limits. S-H image looks off-axis, center is about 5.5 in X, 7 in Y

02:40 - reset telescope, back to star'

collimate_once - done twice, hit limits, coma quite bad. IDL was sending
   Z4=1222, Z7=258

02:50 - clearing active optics, back to the look-up table. Much better! IDL program seems to be messing us up.

02:58 - Preset to WT10-217F, guided. Only using lookup table....

03:00 - acquired WFS image with IDL but did not send the corrections. WFS image is mis-centered even though we're on axis, and falling off edge. What is wrong?

image: /OldRepository/AGW_Data/20100927/wfsc000008.fits looks fine and well-centered on GRIN array, but extracted wfsc000008_dd.fits as displayed by IDL is off center. IDL program is mis-centering the HS image - central obscuration is at X=5 Y=7, offset about 2 grid spaces in X axis.

We are not going to trust this anymore, and instead try to make do with the collimation table as is.

At this point we have no active optics backup on-site, so we will muddle through as best we can

Slit Scan to determine/confirm Rotator Zero Point

03:05 - setting to Stone-O star (guide preset) - maybe 1.6as seeing.

Re-running slitscan from last night to try to verify if our correction of LEFTZEROPOINT from 30.0 to 30.157 had the right sign. This test last night was interrupted by the slit mask fault and we never got to make the verifying observations.

The red channel only is being used, IMCS active (and working great!), 30s integrations in an SDSS r filter, 3Kx3K imaging ROI.

03:13 - started, probably 1.5as seeing - Measure a 30s image at SDSS r as 1.3arcsec w/o WFS collimation.

Note: we are getting about 15000ADU in 30sec on r=14.8 in this seeing (0.122 arcsec/pixel)

03:22 - Collimation is getting worse since WFS is not running. Getting oval and fuzzier, guider having difficultly.

03:23 - script done, read running preset. going to give IDL WFS stuff one more chance...

Results are ugly: the central obscuration is at X=2, it's finding algorithm has clearly lost it. Inspecting wfsc000009.fits is slightly on the edge of the GRIN, but that's because it is 3-arcmin off-axis S of the science field center, but still...

Image sequence for slitscan is mods1r.20100927.0022 to 0026

03:30 - angle of the 5 stars is unchanged from last night! Apparently LEFTZEROPOINT was not changed. Nobody here seems to know (a) how to change this value or (b) how to see what the current value is...

03:32 - idea: redo preset with PA=0.157 degrees and see if we can verify the rotation zero point correction sign that way.

Image sequence is mods1r.20100927.0027 to 0031

03:40 - sequence done... Analyzed and we put in the wrong PA to compensate - PA increased the tilt of the nominal NS line...

03:45 - starting third slitscan at PA=-0.157.

images mods1r.20100927.0032 to 0036.

04:00 - finished analysis of run 3. An overlay of the star at the 5 offset positions and an image of the LS6x60x0.6 long slit mask is shown below. This is the right angle!

  • Offset (+30,+15,0,-15,-30) superimposed on the LS6x60x0.6 long slit mask:
    aligned_slit.png

Offset Test

04:02 - using the PA=-0.157 offset that we'll apply to all subsequent observations tonight, we're starting with a quick test of the offsetting precision and repeatability.

Running the dice10 script, which runs the following "5-Dice" offset sequence:
     2  .  1
        0
     3     4
The sides of the square are 20x20-arcsec, so it does 10-arcsec offsets relative to 0,0.

The script runs the pattern 5 times, for 5 measures per position, 25 measures total. It uses absolute offsets, and the images are taken with a 1Kx1K pixel ROI to reduce the readout overhead.

Images will be mods1r.20100927.0037 through 0061, at elevation around 55 to 57 degrees. Cadence for the 30s integrations is about 1 image per minute, so the whole sequence should be done in about 30min.

04:18 - oops. We had the offset commands commented out in the script (leftover from when it was being tested offline earlier yesterday).

Oh well, gives us a guiding in-place stability test... Stopped after image 0051. Seeing is variable, so the analysis will show a lot of the influence of that. Still, what we get for the 17 images with average 1.5 arcsec seeing (12 pixels FWHM), we get RMS centroids of
  sigma_x = 0.52 pixels (63mas)
  sigma_y = 0.41 pixels (50mas)
  sigma_FWHM = 1.8 pixels (220mas)
This is guiding and IMCS correction during 30sec integrations, 17 data points, variable seeing in variable wind conditions. Seeing (FWHM) is definitely correlated with time, getting worse through the image sequence, and both the X and Y measures show trends with time and seeing, so the RMS is larger than if conditions were stable.

04:19 - David tweaking the image quality... seeing kind of crappy, 2-arcsec , wind and humidity are up (73% RH and 1m/sec, gust to 13m/s)

04:22 - starting Dice 10 again, this time with offsets.

Because the seeing is junk we're running it at 2x2 binning (0.244 "/pixel). Why not...

Images: mods1r.20100927.0052 to 0075.

04:49 - seeing continues to deteriorate: now >3arcsec, but of course no active collimation adjustment due to the problems noted before.

04:50 - Guide Preset to Stone-A2. Elevation at start is about 38 degrees.

Seeing about 2-arcsec. David tweaking the PSF. got some improvement on the contrast using the F525LP filter (red-pass "moonlight rejection").

Will be running Dice10 again, this time 1x1 binning since the star is brighter. Seeing maybe 2-arcsec or worse (uncorrected collimation).

05:04 - Doug Miller was watching the wiki and called up. He's taking a look at the WFS images...

05:05 - Dice 10 started, Stone-A2 fied.

Images are mods1r.20100927.0082 through 107 if we don't have problems. Seeing is variable and 2-3 arcsec, with not very round images on the guider, so this is likley not going to be useful for the offset test, even with 2x2 binning.

At least it lets us hammer away at the system...

05:20 - seeing/collimation/focus(?) have seriously degraded, it is basically guiding on fluff

05:29 - DGH tweaked it up, much better - at least as far as image concentration. seeing is still around 2-arcsec and change.

05:30 - running a single Dice10 sequence (5 offsets), just because we can, not much else to do under these observing conditions.

05:37 - Preset to FF0100+41 guiding on star 1237. Field for high elevation Dice5 runs.

A brighter (mag=12.4) guide star. DGH tweaking the PSF. Some of it was focus change, temperature has dropped about 2C in the past hour.

05:42 - started Dice10 run on the target field. Elevation 61deg

Seeing about 1.5 arcsec, maybe mostly defocus due to T drop before. We'll watch it through this sequence.

Images: mods1r.20100927.0107 thru 0132 if all goes well.

First image, 0107, is nice and round, 32K ADU peak, about 1" and change seeing.

WFS Remote Help

05:52 - Doug Miller is back

Taking WFS images from remote.

06:04 Tried to collimate on-axis: Converged in Focus and coma and started send Z4-11. Diverged in Z10. wfsc 11-17. Commented out John's 0.78 degree rotation

06:10 Changed z10 coefficient from +1.7 to -1.7. David cleared C00

06:15 Collimated wfsc 18-23. Converged to <150 nm in two iterations

06:20 Rick and Rebecca send preset to off-axis guide star. Failed to acquire guide star. Coordinates look fine. Rick is taking MODS image.

06:25 Resend preset in ACQUIRE mode. No off-axis star. Reset guide probe and resend

06:27 Find guide star on edge of 50" field. David is resetting pointing model. IE = -39 CA = 13

06:38 Preset to off-axis guide star

06:42 x = -61, y = -139. Collimate_multiple, 7, /SEND Send big coma the first image (wfsc 24) and then sent a z4-11. Somewhat big Z11 ~150, several times. wfsc 30 is below 250 mn.

06:50 Put John's 0.78 degree rotation back in. Now collimating to about 300 nm rms

06:58 Preset so x=78, y = -129, Pupil is off one subap. wfsc 45-51

07:08 Turn IDL collimation (collimate_multiple, 100, /SEND) over to the mountain. Doug will tweak parameters a bit and call the mountain later.

Back to Dice testing

07:12 - back to work, now operating the WFS via IDL after expert help from Doug Miller...

Running Dice10 on the field at El=80. Using
collimate_multiple, 100, /send
to operate WFS collimation correction. So far nice round guide star and about 1-arcsec seeing. Much much better...

Images: mods1r.20100927.0121 to 0146 for this run, El=80, 1Kx1K. 3Kx3K snapshot of the whole field at start is image 0120. Sequence is running well.

07:28 - Doug tweaked the IDL routines to give better pupil center location. Stopped and restarted (full reload of IDL) and it is working well.

Premature script abort (happens rarely, but this time it bit us) after image 0142. Not an instrument or telescope system fault.. Oh well.

Image Sequence Test

07:42 - exercising the system. Going to a target field with PA=90, tracking with IMCS, taking a multi-filter image sequence to exercise the instrument and telescope command/control system, and doing a full end-to-end acquire, guide, and collimation lock (if the latter by-hand with IDL).

08:00 - wind increasing, including gusts to 15m/s - seeing is getting very jumpy, images are not round now. WFS is doing well keeping things collimated, but the guider is galloping a bit in the wind.

Images show non-round stars - guiding was galloping in the wind. We're still far from tuned up.

08:21 - trying for another field. Having some problems with guide star acquistion.

GCS is completely failing to grab the only bright star in the entire acquisition field. Repeated preset attempts have failed.

08:27 - restarted the GCS, assuming it lost its mind...

Nope, it has lost its mind. We note the background is hig. The red cross is put up in some random corner (upper left as viewed on the screen), and it does the dance right, but with the wrong center...????

08:35 - went to a faint pointing star and it worked fine.

Is it getting fuddled by the bright background from the moon even with the long-pass filter in the beam.

Moon is 35-degrees from the field... Trying the ND1 filter...

yep - problem is high background - the GCS star finder algorithm is getting fuddled by the high background. When we put in the ND1.0 filter it did fine. Once it settled and started guiding we switched in the F525LP filter to get more signal to guide on. So far so good.

08:45 - starting dither5 pattern run on Stone A2 for astrometric reference

Run 1: SDSS-r, 30s, mods1r.20100927.0159 thru 0164

stars aren't very round - got a pear-shape (coma?) across the field. Some are saturated. WFS collimation maybe not that good?

08:54 - Run 2: SDSS-r, 10s, mods1r.20100927.0165 thru

09:00 - redo on Run 2, had exptime 30 instead of 10s...

Images: mods1r.20100927.0166 thru 0170

Guider images don't look that great - seeing a big of trefoil in the shape. WFS is not correcting this. See image mods1r.20100927.0166.fits for an example. The guide images seem to show some coma, this is visible in the science images as well.

09:20 - Seeing some Z10 terms in the WFS corrections, see eg wfsc000196-198.

09:24 - Re-doing the SDSS r dither sequence, corrections look better.

Images: mods1r.20100927.0181 thru 0185

Image 0181 looks better now, perhaps the WFS is doing better at correctiong (we're around wfsc000200+). Of course the seeing is starting to fuzz out, and there are clouds visible in the moonlight.

MODS Science Field Center-of-Rotation

09:36 - seeing is getting bad and cloud coming in. No point in trying the transformations in this seeing as we'd be dominated by seeing effects and get lousy centroids.

Measuring center of rotation of the red science field. Slew to 0 degrees, start 90s exposure on the science camera, then slew to 360 degrees.

Image: mods1r.20100927.0186.fits

09:43 - Repeating, I forgot to disengage the IMCS and it was doing its best to follow, unsuccesfully.

Repeating with the IMCS open-loop. We'll still see all the flexure in the instrument...

See image mods1r.20100927.0187.fits - pretty cool, and it looks like the center-of-rotation is pretty close to the center of the red CCD at least, which is pretty close to the center of the sieve mask pinhole pattern.

  • MODS1 red channel Center-of-Rotation test:
    mods1r_CoR_sdss_r.png

  • this picture was processed with a quick-n-dirty bias and sky flat, the sky flat was kind of nasty, though. At least it takes out the differences among the quadrants.

Couldn't ask for more (OK, we could, but by now we know better).

09:47 - High, thick clouds coming in, not looking so good.

Acquisition Test

Given the increasing background, we tried acquiring an IC1613 photometric reference field with a faint-ish (15.1mag) guide star.

1015 - got the failure again, here's a snap of the Acq Image. Note the location of the star and the red cross which is what it thought was the brightest thing in the field - it is background, but there is darker background due to the field stop on the guide camera entrance aperture. We used the ND1.0 filter on the camera.

  • GCS acquire fail:
    GCS_guide_fail.png

  • Target: 01:04:59.986 +02:06:57.83
  • GStar: 01:05:03.03 +02:04:53.3

1017 - got success using a 15 mag star nearby - go figure.

  • Target: 01:04:36.217 +02:06:57.83
  • GStar: 01:04:45.11 +02:02:36.8

Moon is about 35-degrees from this field, and there are high clouds over much of the sky.

1031 - Try again, ND1.0 filter in, field that succeeded failed on another tru.

Acquisition images are /Repository/GCSfiles/dailyimages/acquire000***.fits, as follows:

  • 133 - first image after preset, guide star in field
  • 134 - second image, telescope move, now star is off field
  • 135 - third image, no star in field

This shows the sequence of images that were obtained on a failed preset.

Did it again, this time without the ND1.0 filter.

  • 136 - first image after preset, star again in field, nice and bright
  • 137 - second image, telescope move, star is gone
  • 138 - third images, maybe star off the right edge

A suggestion is that in high background, the field stop in the camera is obvious, and the search algorithm is somehow thinking the bright square of background is a "star".

I copied image acquire000136.fits from the Repository and examined it in XVista.

Using a modal sky algorithm (standard astronomical practice) I get a sky level of 544+/-41 ADU. A sky threshold cut (conservative) of 5-sigma above sky would ignore all pixels with values less than 544+5*41=749ADU. If I do that, the only target above threshold in the field is the star which has a peak pixel of 5345 ADU (total), or 4801 ADU above the modal sky level.

The data values in the shadow of the MODS AGw unit field stop is about 210 ADU. If for some reason the guide star acquire search algorithm was computing the "sky" level as 210, it might be fooled into thinking the entire bright square of real sky was somehow an object, and it would get a false centroid to try to put that into the point center, failing.

10:50 - This is driving us crazy.

So, we pointed at a field, picked a guide star, and then did an ACQUIRE preset. When it landed on the field, we manually moved the guide stage to put the guide star into the WFS hotspot.

Using the IDL program, we got a decent collimation correction, by hand.

We were on-target, admittedly tracking open loop, in under 2 minutes. Over short periods the open-loop tracking of the LBT and LDG rotator are quite good, we have captured some very nice images in 30s integrations. This was to bide the time until the bank of clouds passed us and the backgrounds went down enough that we could again acquire targets.

11:28 - Background still a problem, WFS and open-loop operation

Just for grins because the background problem is dealing us fits. We have no problem tweaking the star down the hotspot with the guide probe stage to keep up with WFS corrections run one at a time. Conditions preclude trying to do anything useful, and it is near the end of the night anyway...

We got nice round images in 30s integrations with 0.8 arcsec FWHM. See below:

  • M1 SDSS r - open loop, WFS by hand:
    m1_r_byhand.jpg

11:42 - Clouds have moved on, backgrounds smaller, trying a preset.

Succeeded, background are lower, but not that much lower. Must be a threshold thing.

Locking on with the WFS in manual IDL mode. Looks nice.

Astrometric Calibration Fields - first cut

11:55 - Going after one of the Orion astrometric fields, since seeing has gotten quite better and the clouds are gone.

Setup at PA=90 on the Orion Jones & Walker field 107, got a good guide star lock (backgrounds better).

However, starting to get wind gusts to 15m/s and seeing is starting to go variable on us - after nearly 0.7 arcsec FWHM not 10 minutes ago... Collimation pretty solid, looks nice.

Images: mods1r.20100927.0207 thru 0214

12:10 - Guide Camera astrometric calibration.

Using an Orion Jones & Walker field center on star Orion P467. Will do an track preset to the star with the F525LP filter in place, then drive the probe to the field center. Images will be acquired manually using the readGuideCam program.

Got close, but by 12:33 we lost the race with the sunrise. Oh well, next time...

-- RichardPogge - 26 Sep 2010

Topic attachments
I Attachment Action Size Date Who Comment
GCS_guide_fail.pngpng GCS_guide_fail.png manage 178 K 27 Sep 2010 - 10:18 RichardPogge GCS acquire fail
aligned_slit.pngpng aligned_slit.png manage 143 K 27 Sep 2010 - 04:02 RichardPogge Offset (+30,+15,0,-15,-30) superimposed on the LS6x60x0.6 long slit mask
m1_r_byhand.jpgjpg m1_r_byhand.jpg manage 97 K 27 Sep 2010 - 11:37 RichardPogge M1 SDSS r - open loop, WFS by hand
mods1r_CoR_sdss_r.pngpng mods1r_CoR_sdss_r.png manage 773 K 27 Sep 2010 - 09:55 RichardPogge MODS1 red channel Center-of-Rotation test
This topic: Commissioning > Main > WebHome > Com20100927
Topic revision: 27 Sep 2010, MarcoPedani
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback