AGw Commissioning with IRTC 06-07 November 2008 MST

Observers: Hill (at beginning), Miller, Rakich in Tucson, J.Storm from Potsdam
Software Support: on call as needed.
Telescope Operator: A.Ceranski

Summary

Details (times reported in MST below)

Aaron started up the the telescope with no problems.

Correct pointing, initial collimation

5:30 Aaron open chamber and start all systems. All worked well. He sent a presetTelescope (from PRESETGUI) and slewed properly.

5:50 presetTelescope M5_0881 Tel="TRACK". First two return quickly with success, but Aaron reports that the rotator was not moving. He reset PCS to get moving. IRAF should catch this return error (Aaron says IIF report that rotator is not moving..or something), but IRAF reports success. Dave Thompson? IIF error message at 18:12 "mcpsu returned: no polys are being received". Two presets were sent and this was the error both times. After restart of PCS, preset worked

Note from D.Thompson:  I found and corrected a logic error on handling of the result codes returned from IRS, but note that the presetTelescope command itself properly reported that it encountered a problem.  In /home/LBTO/iraf/LOGs/pointto_011208.log there is:

   irc PresetTelescope 0. POSITION TRACK left
   > Problem with PresetTelescope command.  res=1

The corrected LBTtools packages have been uploaded to the mountain

6:10 Found star at offset -60 30. IE=45, CA=-69

6:20 All global offsets are 0.0. A lot of focus so set Z=0.8. OK focus, but can see coma. Should there be global offsets? John Hill, did you fold these values in to the collimation model? JMH:Yes, the global offsets have been incorporated into the collimation model.

6:55 IE=-25.0 CA=-70.0 with offset 0 0

7:10 presetTelescope BS9188 Tel="ACTIVE" gstar=0

7:20 well collimated in 6 iterations (WFE < 400nm rms). Still see higher order aberrations

7:30 oacserver and port forwarding all work!! Great!!

7:44 all z4-z11 corrections are below 120 for last 20 iterations (now on 030)

7:45 preset BS9188 Tel="GUIDE" gstar=0

7:49 agw_collimate, EXP=30 (got image but failed. My IDL bug that I need to fix!!). Try again. All data in /Repository/AGW_Data/081107w

7:53 image is getting out of focus enough in about a minute that can see a donut of spherical!! Troubles in my IDL routine irc_sendwavefront.pro. About guide image 390-405.

8:39 Fixed irc_dd.dat file. Getting " " for two DD variables so not able to parse the return string.

8:41 wfsc 17 large RMS WFE so only send Z4,7,8. wfsc 18 send Z4-11, Bad new influence fuctions error from PSF. Not applied.

8:43 clear C00 to clear all primary forces. Get focus and see spherical

8:44 start collimation with "smart zernikes" (converge Z4,Z7,Z8 before trying higher order corrections) wfsc 19-31

9:02 clear C00, set zernike_rms_low_order = 0.0 so we only send z4-11 to compare convergence to z4-z22 above.

9:02 wfcs 32-37

9:12 put Z11 +1000 (z_act before = -0.168, z_act after = -0.022) wfsc 38 measure/send to psf z4=343 z11=-940

9:15 collimate M1 wfsc 39 measure/send to psf z4=182 z11=-935

9:17 collimate M1 wfsc 40 measure/send to psf z4=42 z11=-687

9:19 put Z11 -1000 (total z11=0) wfsc 41-44

9:25 restart IDL with zernike_rms_low_order = 500.0 so send z4-z22 wfsc 45-51

9:33 put z4 +1000 (total = 1000) wfsc 52-54 z4=775, 741, 583

9:34 put z4 -1000 (total = 0) Z_act_1000=-0.243 Z_act= -0.281 collimate wfsc 55-56

9:40 put z4 -1000 (total = -1000) wfsc 57-59 z4=-442, -522, -600

9:42 put z4 +1000 (total = 0) Z_act_-1000=-0.335 Z_act= -0.297 wfsc 60-62

9:50 presetTelescope M5_1040 Tel="ACTIVE" gstar=3 Failed, no star

10:00 John preset to onto on-axis M5 star and reset IE=-2, CA=-60

10:20 Set IRTC to 5"x5" plate scale

10:30 tweaked guide probe x, y to center star on IRTC

10:47 focus 32.8 takeseq 0.05 1000 50Hz /Repository/IRTC_Data/08107/focus_32.8_00002_cube.fit

10:49 setfocus 35.8, takeseq 0.05 1000 50Hz focus_32.8_00003_cube.fit (collimation correction applied)

10:53 takeseq 0.05 1000 1000 Hz focus_35.8_00004_cube.fit

10:57 takeseq 0.05 1000 1000 Hz focus_29.8_00005_cube.fit

11:10 takeseq 0.05 1000 1000 Hz focus_26.8_00006_cube.fit

11:30 We have been collimating with GCS (Z4-11) for the last hour, up to wfsc 110

11:30 presetTelscope to Jesper's Object IC166 01:52:21.99 +61:51:57.9, no star seen on IRTC

11:39 use irc_preset_guide to go to IC166

12:20 Take IRTC data

1.0 10 ic166_000007
1.0 25 ic166_000008
1.0 50 ic166_000009
1.0 10 bg166_000010
1.0 25 bg166_000011
1.0 50 bg166_000012

12:39 setxy -x 0 -y 612.5 (get -0.015, 612.498)

12:40 Take 50 sec exposure with rotator from 350->0 /Repository/AGW_Data/081107g/guider000102.fits

12:41 Take 50 sec exposure with rotator from 0->350 /Repository/AGW_Data/081107g/guider000103.fits

1:00 stopAGW, oacsrv stop (doesn't do it so have to kill -9), oacsrv start

1:01 get AGW RPC Communication error in GCS.

1:10 stop, start GCS. Send preset to IC166 Success

1:15 collimate wfsc 68-71

1:22 stopGuiding, setxy -x 0 -y 612.5 (get 0.029, 612.499)

1:23 setExpTime 2000.0 many stars

1:25 Take 50 sec exposure with rotator from 350->0 /Repository/AGW_Data/081107g/guider000146.fits Too crowded!

1:27 set IE=-10, CA=-55 to get less crowed field 0->350 guider000176.fits

1:30 350->0 guider000177.fits Jesper says "hmmmm" which means the center positions from the two images are different. Try again

1:38 0->350 guider000178.fits

1:39 350->0 guider000179.fits

1:46 Aaron stop and start oacserver, home motors

1:54 preset works (eg GCS reconnected to oacserver after it's restart) Guide failed because I had set the exposure time to 60 sec

1:56 preset fail with no star. I had moved the bright star off the Guider. Change IE, CA so is on hotspot.

2:01 preset (took 50 sec, why so long?) finally get couldn't move guide probe at 2:02:55

2:04 preset work. collimate wfsc 72-75

2:16 stopGuiding

2:19 TORSTEN!! I executed "readGuideCam 1" and it was very slow. It took from 2:19:10 to 2:19:35

2:20 350->0 guider000224.fits

2:21 0->350 guider000225.fits

2:23 350->0 guider000226.fits

2:25 0->350 guider000227.fits

2:31 and 2:33 preset fails because GCS error "Could not move probe to position"

2:35 preset success. Nothing has changed. Guiding and Collimating

2:42:00 preset M38 ACQUIRE Failed irc returned error "rejected change of guidestar list as GCS is actively guiding or WFSing". CGS error " WFSing thread unexpectedly stopped! Therefore GCS adjusts its own start to not WFSing"

2:45 preset to M38 failed "could not move probe to position"

2:54 GCS collimated ~114 to 119

3:02:04 sent a stopGuiding via command line. GCS error "GCSL died unexpectedly", "GCSL is not active" etc etc

3:04 Aaron restarted GCS

3:06:28 requested guider image with readGuideCam. GCS failed with error "AGWunit init(): _filterPosition...bla bla bla"

3:07:43 GCS error "didn't create a new instance....bla bla"

3:13:55 Aaron stop and start GCS.

3:14 request guide image with readGuideCam. OK

3:20-3:24 take bunch of astrometric data with guide camera /Repository/AGW_Data/081107g/guider0000316.fits to 346.fits

3:25 move guide probe out of the way. Take astrometric data 1.0sec x 50 images of M38 /Repository/IRTC_Data/081107/m38_00013_cube.fit, 14, offset 5" in DEC, 15, offset back to 0, 16, 17

3:50 preset M5_0258 success. No star, found with spiral search IE = -20 CA = -64

4:11 preset M5_0258 "ACTIVE" gstar=3

4:12:06 "could not move guide probe" error in GCS, preset failed

4:13 preset M5_0258 failed "guide probe" failure

4:15 Aaron stop and start GCS (GCS may not be the problem, but worth a try)

4:18 GCS died unexpectedly

4:23 stopAGW, kill oacsrv, oacsrv start, startAGW, home 1, 2, 4, 16

4:26 preset M5_0258 "ACTIVE" gstar=3 Success

4:26 preset M5_0258 "ACTIVE" gstar=4 Success, PA=228 collimate through 142

4:53 preset M5_0258 "GUIDE" gstar=* PA=228

5:12 confused about why star on IRTC moves so much when go to another guide star

5:12 guide on axis, set IE=-22 CA=-62

5:15 guide and collimate on gstar=4 through 155

id X Y dist(") IRTC exp frames
4 2.245 468.403 240.4 M5_0258_00019_cube.fit 0.002 1000
2 71.452 514.166 203.4 M5_0258_00021_cube.fit 0.002 1000
3 -128.069 594.051 215.9 M5_0258_00020_cube.fit 0.002 1000
5 -61.478 480/982 242.3 M5_0258_00025_cube.fit 0.002 1000
6 109.516 516.826 242.6 M5_0258_00022_cube.fit 0.002 1000
7 103.88 505.074 249.4 M5_0258_00023_cube.fit 0.002 1000
8 -71.494 473.679 260.0 M5_0258_00024_cube.fit 0.002 1000

6:00:50 Guide on-axis Preset failed Aaron killed GSC and preset returned

6:05 preset on-axis. M5_0258 not on guider hotspot. move IE=-18 CA=-62

6:09 move guide probe out of the field. See M5_0258 about 2" from original position at 5:12

6:14 Aaron send rotator for 350->0 M5_0258_rot_00026_cube.fit 0.002set 1000 frames @ 5 Hz

6:20 IRTC background M5_0258_rot_00027_cube.fit 0.002sec 1000 frames @ 1000 HZ

-- DougMiller - 07 Nov 2008
Topic revision: r6 - 08 Nov 2008, JohnHill
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback