(adsec) change_elevation_limit script upgrade test

Software: XZ
AO: XZ, GB

Problem

DX ASM had a failure on April 26 08:55 UT. The cause is that the changing of elevation limit had failed. The changing of elevation limit failure happened when changing the limit for AdamHousekeeper, while the limit changing for AdsecArbitrator was succeed. Note: the same change_elevation_limit script was successfully executed on SX ASM side.

Solution/Upgrade

  • Identify the command execution is failure or not:
    • checking the outputs of the elevation limit change commands
    • read back the current elevation limits
    • check the current elevation limits
  • Give the user clear info about the commands results (failure or not)
  • Give instructions if the commands fails
  • To make the script more reliable, executing the two limit changing commands in the same "terminal".

Code change

Please see the modified code in Github (here)

Test plan

The test will be performed on both SX and DX ASM:

Please see the original test plan: change_elevation_limit script upgrade test.xlsx

Please see the modified test plan: change_elevation_limit script upgrade test v1.xlsx

Test results

The tests were executed on April 28, 2022

Please see the test results on SX: change_elevation_limit script upgrade test SX.xlsx

Please see the test results on DX: change_elevation_limit script upgrade test DX.xlsx

In short, the tests were successful.

Last status

The new upgraded scripts are installed on both sides, i.e. SX and DX. April 28, 2022

-- XianyuZhang - 28 Apr 2022
Topic revision: r2 - 28 Apr 2022, XianyuZhang
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback