SX WFS Startup and Checkout

20:36
  • Waiting for the telescope
21:00
  • The fastlink is working properly.
21:21
  • Beginning tests.
21:33
  • It looks like, at 341 degree LUCI rotator angle, the camera lens doesn't have enough range to center the pupils. In the Y axis, it centers, but in X, we still have 1.5 pixels of offset.
  • This means that we can't close the loop at a 341 degree rotator angle, except in TT, or 12 modes. I'm going to 200, to see if the camera lens will center the pupils.
  • I moved the rotator to 90.
  • Camera lens X is still at 100.0um
21:46
  • Hexapod: 3.665 3.960 -0.710 -231.398 -118.464 0.0
  • Baysides. -76.8 -51 52.524
  • Best rotator angle is 110, camera lens is at 88.83um in X
21:54
  • Doing step 2.
  • Loop is stable. 1700Hz. A lot of vibration as LN required that the telescope be completely locked out, no HBS.
  • Reconstructor is the one from table_LUCIFER_ACE-AO.txt: Rec_20181215_201757.fits
  • Tracking numbers with OCAM2 Frames: 20190525_215749, 215916, 215932, 215956
  • There are errors in pup_diag_unbal.pro:
  • % Compiled module: AOFRAMES__DEFINE.
    % Attempt to call undefined procedure/function: 'AOTIMESTAMPS__DEFINE'.
    % Execution halted at: AOELAB::INIT 270
    /home/AOeng/aoroot/idl/elab_lib/aoelab__define.pro
    % OBJ_NEW
    % AOMULTITON_ELAB::GETOBJ 38
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % GETAOELAB 106
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % PUP_DIAG_UNBAL 10
    /home/AOeng/SOUL/pup_diag_unbal.pro
    % $MAIN$

  • Testing with ONLY OCAM2 frames
  • gain 0.73 0.18 0.18
  • 220748, 220802, 220813, 220825
  • Same error as above.
  • 500Hz
  • Gain: 1.72 0.25 0.09
  • 221233, 221250, 221309, 221328
22:23
  • Step 3a
  • 1700 Hz
  • Dark for LUCI: 20190525_222559
  • Gains: 0.36 0.14 0.09
  • Turning on NCPA, to make the PSF look better.
  • Proper disturbance for 1700Hz: /local/aomeas/adsec_calib/M2C/KL_v20/disturb/CmdDisturb_20190313_032434.fits
  • Can't get elab to work properly, can't make c2m matrix in order to make GOPT work properly.
  • % Attempt to call undefined procedure/function: 'AOTIMESTAMPS__DEFINE'.
    % Execution halted at: AOELAB::INIT 270
    /home/AOeng/aoroot/idl/elab_lib/aoelab__define.pro
    % OBJ_NEW
    % AOMULTITON_ELAB::GETOBJ 38
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % GETAOELAB 106
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % AOELAB::INIT 270
    /home/AOeng/aoroot/idl/elab_lib/aoelab__define.pro
    % OBJ_NEW
    % AOMULTITON_ELAB::GETOBJ 38
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % GETAOELAB 106
    /home/AOeng/aoroot/idl/elab_lib/getaoelab.pro
    % $MAIN$

  • Whatever, here are your datasets.
  • 223849, 224439, 225037, 225602, 230121, 230807

-- GregoryTaylor - 25 May 2019
Topic revision: r1 - 25 May 2019, GregoryTaylor
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback