SX Flat and Actuator Tests

17:30 Clicked the Loop Params "Apply" button and msgdrtb and many other processes died

WfsArbitrator_69280|DEB|       139|2017-05-04 17:30:06.184587|             MAIN > arbFunc modifyAOInternal (, 'FLAOWFS', '', 990, 1, 3, -1, -1, 1, 'False')
WfsArbitrator_69280|DEB|       140|2017-05-04 17:30:06.414069|             MAIN > ('selected program 1x1, 2500 kpix/sec',)
WfsArbitrator_69280|DEB|       141|2017-05-04 17:30:06.414115|             MAIN > ('Delay base 949, delay inc 1, repetitions 61',)
WfsArbitrator_69280|DEB|       142|2017-05-04 17:30:06.414150|             MAIN > ('Real framerate 989.609104 Hz',)
WfsArbitrator_69280|ERR|       143|2017-05-04 17:30:11.559600|             MAIN > thGetVar ccd39.L.ENABLE.CUR error(-5001): Timeout error

[AOeng@flao-sxwfs ao]$ w_check
Configuration directory: /home/aoeng/aoroot/conf/wfs/current/processConf

msgdrtdb             NOT running
mirrorctrl           running but NOT connected to Msgd
pinger               running but NOT connected to Msgd
masterdiagnostic     running but NOT connected to Msgd
od_gopt              NOT running
slopecompctrl        running but NOT connected to Msgd
techviewctrl         running but NOT connected to Msgd
powerboard           running but NOT connected to Msgd
bcurelays            running but NOT connected to Msgd
picctrl              running but NOT connected to Msgd
ccd39                running but NOT connected to Msgd
ccd47                running but NOT connected to Msgd
ttctrl               NOT running
adc1                 running but NOT connected to Msgd
adc2                 running but NOT connected to Msgd
filterwheel1         running but NOT connected to Msgd
filterwheel2         running but NOT connected to Msgd
rerotator            running but NOT connected to Msgd
mercury              running but NOT connected to Msgd
cubestage            running but NOT connected to Msgd
baysidex             running but NOT connected to Msgd
baysidey             running but NOT connected to Msgd
baysidez             running but NOT connected to Msgd
cameralensctrl       NOT running
housekeeperWFS       NOT running
optloopdiag          NOT running
pupilcheck39         running but NOT connected to Msgd
dbfiller             running but NOT connected to Msgd
truesense            running but NOT connected to Msgd
wfsarb               running but NOT connected to Msgd
gopt                 running but NOT connected to Msgd
No AdOpt processes are running

17:35 w_stop/start
  • on WFSARB Control GUI click "Off"
    • anything left on should be now off
  • Click "Operate"

17:41 Act 2 is saturated after load program
  • Try set and get "An in-use Actuator..."
  • Failed state
  • Click Recover Fail
  • Panic State
  • At IDL prompt: print, fsm_power_off()
  • Stop/Start AdSec Arbitrator
  • Click On
  • Click Load Program
  • Act 2 is OK now

17:46 Set
  • default.sav = 667 modes
  • 20150513_181300.sav = 667 modes
  • With flat, high forces on 32 with -0.32N, 261 with 0.20N, 332 with 0.17N, no other actuators with more than 0.1N
  • Opt Gain 1.23, 0.55, 1.45
  • Data 183518, 183546
  • Set Gain 1.23, 0.55, 0.5
  • Data 183701
  • Flat old_flat_183701_400
  • CL have high force on 451 with 0.35N, 165 with 0.24N, 450 with -0.27N, 463 with -0.23N, 477 with -0.27N, 578 with -0.26N
  • looks like 451 is pushing and 450 and 477 are pulling. Put 451 in no_icc
  • load flat old_flat_183701_400
    • 451 was fine then jumped to 0.8N for a few seconds and then back to OK
      • Will watch, but not put in a list yet
    • With flat high force on 6 with -0.27N, 149 with 0.19N, 37 with 0.18N, 7 with 0.18N, 564 with 0.17N, no other actuator with more than 0.12N
    • In CL high force on 149 with 0.27N. 150 with 0.19N, 332 jumped to -0.29N, no other actuators with more force than 0.18

19:16 Restart and Set
  • 541 saturate when doing Load Program
  • Power off/on and Load Program. Success
  • Flat old_flat_183701_400
    • High forces on 261 with 0.2N, 37 with 0.18N, 7 with 0.18N, 564 with 0.17N, 6 with -0.27N, 0 with -0.15N, no other actuator with more than 0.12N
  • Data 192925
  • Flat old_flat_192925_400
  • Apply new flat
    • 667 modes
    • High forces on 37 with 0.18N, 7 with 0.18N, 564 with 0.17N, 6 with 0.18N,
  • CL
    • High forces on 1 jumping from <0.2 to -0.27N,150 with 0.23N

19:40 CL with 0.8" disturbance
  • Opt Gain 1.23, 0.81, 1.45
  • Data 194330, 194343
  • High forces on 451 with -0.33N, 511 with -0.32N, no others above 0.28N

19:48 CL with 1.5" disturbance
  • Opt Gain 1.23, 1.0, 1.45
  • Data 195156
  • Set Gain 1.23, 1.0, 1.0
  • Data 195303
  • Opt by hand Gain 1.48, 1.05, 1.05
  • Data 195442

19:54 CL with 3.0" disturbance
  • Opt Gain 1.23, 1.0 1.45
  • Safe skip, open loop after Opt Gain was done. Pupil Center was still off

20:03 Hexapod stuck
  • 4.92, 2.64, -0.35, -76, 122

20:10 Try 3.0" again
  • Opt gain OK but then lower left edge then rolls under

20:14 CL with 2.4" disturbance
  • Opt Gain 1.23, 0.9, 1.45
  • Data 201635
  • Opt Gain by hand 1.53, 0.9, 0.9
  • Data 201758

20:22 Done with actuator removal
  • Use old_flat_192925_400.sav

20:28 CL with 0.8" disturbance, 400 Modes
  • Opt Gain 1.23, 0.75, 1.45
  • Data 203014
  • Opt Gain by Hand 1.43, 0.75, 0.75
  • Data 203140, 203153

20:35 CL with 0.8" disturbance, 300 modes
  • Opt Gain 1.23, 0.9, 1.45
  • Data 203739
  • Opt Gain by Hand 1.48, 0.95, 0.95
  • Data 203913, 203932, 203949

20:49 CL with 0.8" disturbance, 400 modes
  • dist_flao2_KL_v18_...1000...fits
  • Opt Gain 1.23, 0.7, 1.45
  • Set Gain by hand 1.33, 0.7, 0.7
  • Data 205310, 205326

20:54 CL with 1.5" disturbance, 400 modes
  • same as above
  • Set Gain by hand 1.65, 0.75, 0.7
  • Data 210057, 210124
  • Gain 1.65, 0.75, 0.55
  • Data 210239
  • Gain 1.65, 0.75, 0.40
  • Data 210326

21:43 Revert back to operational AO Supervisor on AdSec (with many bad actuators)
  • default.sav = 620 modes

21:47 CL with 0.8" disturbance, 400 modes
  • dist_flao2_KL_v18_...1000...fits
  • Opt Gain 1.27, 0.49, 0.41
  • Data 214821, 214843
  • Set Gain 1.42, 0.59, 0.51
  • Data 215404, 215504

23:03 Add actuators to no_curr list to be consistent with IM
  • act not in IM: 2,14,32,165,373,451,511,539,578
  • 383 modes
  • Set Gain 1.2, 0.6, 0.45
  • Data 231028, 231134

-- %USERSIG{DougMiller - 2017-05-04}%
Topic revision: r4 - 08 May 2017, DougMiller
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback